Gauge result appearing as 1.00 in Pulse

I have built a dashboard with Gauge and Number results using SQL. These appear as expected on the dashboard. I am now attempting to create a Pulse with those same questions. The Number results appear as expected, but the Gauge results are always “1.00”. It shows this incorrect number when creating the Pulse, in Slack, and in email.

Is there a known issue with Pulse and Gauges? I’ve tried adjusting my query and the Gauge formatting but not seeing any changes in Pulse

I thought this value was being rounded as it is a percentage >99%, but when changing to normal number on the Gauge it still displays 1.00 in pulse. I also tried changing the formula completely but still displays 1.00

Hi @jr4801234
Please post “Diagnostic Info” from Admin > Troubleshooting.
I’m having difficulties reproducing with Sample Dataset or static SQL, but it would be helpful if you can reproduce with that database.

Hi Flamber,

Please see Diagnostic Info below. The sample dataset does not contain the correct data types for me to reproduce this query as it is calculating time (in minutes) between two dates.

Thank you!

{
“browser-info”: {
“language”: “en-US”,
“platform”: “MacIntel”,
“userAgent”: “Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/84.0.4147.135 Safari/537.36”,
“vendor”: “Google Inc.”
},
“system-info”: {
“file.encoding”: “UTF-8”,
“java.runtime.name”: “OpenJDK Runtime Environment”,
“java.runtime.version”: “1.8.0_252-b09”,
“java.vendor”: “Oracle Corporation”,
“java.vendor.url”: “http://java.oracle.com/”,
“java.version”: “1.8.0_252”,
“java.vm.name”: “OpenJDK 64-Bit Server VM”,
“java.vm.version”: “25.252-b09”,
“os.name”: “Linux”,
“os.version”: “4.14.173-137.229.amzn2.x86_64”,
“user.language”: “en”,
“user.timezone”: “UTC”
},
“metabase-info”: {
“databases”: [
“mysql”,
“mongo”
],
“hosting-env”: “unknown”,
“application-database”: “mysql”,
“application-database-details”: {
“database”: {
“name”: “MySQL”,
“version”: “5.7.22-log”
},
“jdbc-driver”: {
“name”: “MariaDB Connector/J”,
“version”: “2.5.1”
}
},
“run-mode”: “prod”,
“version”: {
“tag”: “v1.36.4”,
“date”: “2020-08-19”,
“branch”: “enterprise-release-1.36.x”,
“hash”: “0324e9c”
},
“settings”: {
“report-timezone”: null
}
}
}

This is caused by Pulses not applying formatting:
https://github.com/metabase/metabase/issues/3735 - upvote by clicking :+1: on the first post