Getting 400 with SMTP mail server

I'm using metabase docker version of 0.47.10 and i trying to set-up alert for email but getting 400 while calling POST api. There is no firewall blocking, or other networking issue because am able to connect to the database. I set up alert with slack as well, it's working fine. Issue with only GMAIL alerts.

Email configuration details:
SMTP Host:
Port: 587
Note: while am giving my email and password, getting an error as "wrong username & password". But am using the same creds everywhere and it's correct and working fine in other places.

ERROR logs
[e8d292ad-2683-46be-b2b0-f0e7d422336d] 2023-12-28T23:12:40+05:30 WARN Problem connecting to mail server: 534-5.7.14 <
534-5.7.14 qChqRcQ2thfGUznu6MtoskWvbz8VAjIkSxbl0yfi1SOOknRypLJoJU0r2Pm-fgYJpQ79b
534-5.7.14 t3Z6RCuOeoTtggGDGseDeddqNbbfnyNCp2DD5IOs8iZoORqrnRkWzCbFUYP4DKAx>
534-5.7.14 Please log in via your web browser and then try again.
534-5.7.14 For more information, go to
534 5.7.14 Can't sign in to your Google Account - Gmail Help iw19-20020a170903045300b001d0b6caddb1sm14205335plb.137 - gsmtp
[e8d292ad-2683-46be-b2b0-f0e7d422336d] 2023-12-28T23:12:40+05:30 DEBUG metabase.server.middleware.log POST /api/email/test 400 1.9 s (1 DB calls)
{:errors {:email-smtp-username "Wrong username or password", :email-smtp-password "Wrong username or password"}}

have you tried that?

Hi @Luiggi, i tried using APP Password and it worked fine now.
Step i did:
Created APP Password of my gmail account and given the same username and password in Email setting in metabase. Finally it's started working. Thanks!!!