Google OAuth (no username/password) disabled Admin access

Hi there, hoping this is a quick fix and/or a Metabase team member can help as this has locked our team out of admin permissions. This is using the basic Metabase-hosted instance, connecting to a AWS RDS read replica database.

We enabled Google OAuth, which works, and subsequently disabled the username/password functionality (for security purposes), but now the admin option in the top right corner is gone. Any help here?


Metabase wasn’t able to recognize that user as an admin (or it created another user). You will need to get inside some how (e.g adding env vars to disable forcefully Google oauth) and then tweaking the group mappings or manually sending users to the admin group

"Inside somehow" seems difficult when Metabase is hosting the service and doesn't provide ssh access. How do you suggest resolving? This seems like an email namespace conflict bug to me that isn't reconciling username/password user with Google OAuth user

Hosted customers have a dedicated support channel. Please write to help at metabase dot com thanks