Google SSO login Issues

After Configuring Google SSO for login, The google login is working in some cases and in other cases it gives error "The Window was closed before completing Google Authentication".

Diagnostic Info:
{
"browser-info": {
"language": "en-GB",
"platform": "MacIntel",
"userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 11_2_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.4389.114 Safari/537.36",
"vendor": "Google Inc."
},
"system-info": {
"file.encoding": "UTF-8",
"java.runtime.name": "OpenJDK Runtime Environment",
"java.runtime.version": "11.0.10+9",
"java.vendor": "AdoptOpenJDK",
"java.vendor.url": "https://adoptopenjdk.net/",
"java.version": "11.0.10",
"java.vm.name": "OpenJDK 64-Bit Server VM",
"java.vm.version": "11.0.10+9",
"os.name": "Linux",
"os.version": "4.4.0-1122-aws",
"user.language": "en",
"user.timezone": "GMT"
},
"metabase-info": {
"databases": [
"mysql",
"postgres",
"athena",
"h2"
],
"hosting-env": "unknown",
"application-database": "h2",
"application-database-details": {
"database": {
"name": "H2",
"version": "1.4.197 (2018-03-18)"
},
"jdbc-driver": {
"name": "H2 JDBC Driver",
"version": "1.4.197 (2018-03-18)"
}
},
"run-mode": "prod",
"version": {
"date": "2021-02-16",
"tag": "v0.38.0",
"branch": "release-x.38.x",
"hash": "471aa51"
},
"settings": {
"report-timezone": null
}
}
}

Hi @Sahil
Make sure that third-party cookies isn’t blocked. Check the browser developer console.
This can be caused by adblockers too, so check the settings for those.

@flamber thanks, it worked in my case.

Is there any option to disable login via email and password after enabling google sso ?

Hi @Sahil
If the account is created automatically at login, then there won't be a password login available for that account.
Only the Enterprise Edition has an option to disable password logins.

Hi @flamber, could you explain why I should enable third party cookies to connect to Metabase with google ? I never enable third party cookies anywhere and never had any issue to log in anywhere, and if you ask me, third party cookies should never be enabled anywhere.

@metabas Because the login comes from a popup window, and Metabase is using SameSite=Lax, which browsers now are much more strict about.
We might move to a page-redirect instead of popup, but that is a lot of work too.