Graph Types Unavailable

Hi, am using Metabase via Docker (connecting to Redshift). I have come across a problem repeatedly where most graph types become unavailable when I do the tiniest editing to the query (such as altering the column name) - only table and pie are left.

This remains the case when I set the query back to its original wording. Could anyone please assist?


What version of Metabase are you using, and what OS/browser? Can you replicate this behaviour using the sample dataset?

Thanks Sameer

I’m on version v0.18.1, on OS X - have tried in both Chrome and Safari.

Like I said, often it’s the case that changing the column alias restricts the graphs available. Seems to depend on the table though, but I can’t see what is different in the metadata/column types.

No, wasn’t able to replicate in sample dataset.

In general though, I’d really like to know why this sort of query works fine in table results, but does not seem to be possible as a line graph:

date_part(w, cal_date) as cal_week,
cast(sum(Orders) AS FLOAT) / cast(sum(Clicks) AS FLOAT)*100 AS conv_rate
from weekly_kpis
group by cal_week
order by cal_week


No idea why you’re seeing it. I poked around with some of our datasets and haven’t been able to reproduce it at all.

Can you share the schema + the query with us?

We’ve also re-worked how we do graphing in 0.19 (due this monday) which might fix the problem entirely.

Thanks Sameer, I figured it out - it’s to do with null values in the main fact table. I’m using Redshift so changing the expressions to using NVL() solved it.

Am interested to hear about the new graphing method.

Many thanks.

Huh. We’re seeing other weirdness in handling null values in our underlying charting library –

If you can reproduce what you’re seeing in a fake SQL statement and chime in on that issue, that would be super useful.

Hi Sameer

Ok will do.