Grid map no "Auto binned" on the latitude section

as pic, no "Auto binned" on the latitude section, what's the data type for latitude needs in grip map?

Hi @Jay
Post "Diagnostic Info" from Admin > Troubleshooting, and which database type you're querying.
And what is the database column type of those two columns?

I use ms sql 2019, the columns is dec(18,7)
{
"browser-info": {
"language": "zh-TW",
"platform": "Win32",
"userAgent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.4389.128 Safari/537.36",
"vendor": "Google Inc."
},
"system-info": {
"file.encoding": "UTF-8",
"java.runtime.name": "OpenJDK Runtime Environment",
"java.runtime.version": "11.0.10+9",
"java.vendor": "AdoptOpenJDK",
"java.vendor.url": "https://adoptopenjdk.net/",
"java.version": "11.0.10",
"java.vm.name": "OpenJDK 64-Bit Server VM",
"java.vm.version": "11.0.10+9",
"os.name": "Linux",
"os.version": "5.4.0-70-generic",
"user.language": "en",
"user.timezone": "GMT"
},
"metabase-info": {
"databases": [
"h2",
"sqlserver"
],
"hosting-env": "unknown",
"application-database": "h2",
"application-database-details": {
"database": {
"name": "H2",
"version": "1.4.197 (2018-03-18)"
},
"jdbc-driver": {
"name": "H2 JDBC Driver",
"version": "1.4.197 (2018-03-18)"
}
},
"run-mode": "prod",
"version": {
"date": "2021-03-17",
"tag": "v0.38.2",
"branch": "release-x.38.x",
"hash": "91f0ed6"
},
"settings": {
"report-timezone": "Asia/Taipei"
}
}
}

@Jay Try enabling "Periodically refingerprint tables" in Admin > Databases > (your-db), and do another sync of the database.
If that does not work, then please include the output of /api/field/:id where :id can be found by going to Admin > Data Model > (db) > (table) > (field) :gear: and looking in the URL, which ends with .../:id/general

I think the database sync is ok, when I change field name, use menu sync db schema does work.
the URL is
https://192.168.10.71/admin/datamodel/database/65/table/184/829/general
https://192.168.10.71/admin/datamodel/database/65/table/184/830/general
when use pin map, metabase can Identify longitude and latitude, maybe there is no issue on longitude and latitude fields.

@Jay You are misunderstanding. Binning is done via fingerprinting, so Metabase has to understand the contents of the data to show the correct binning information.

  1. Enabled "Periodically refingerprint tables" and click "Save" in Admin > Databases > (your-db)
  2. The click "Sync database schemas now" in Admin > Databases > (your-db)
  3. Look in the log and wait for sync to finish - Admin > Troubleshooting > Logs
  4. Refresh your browser and try to bin the fields

Go to these addresses and post the content here:
https://192.168.10.71/api/field/829 and https://192.168.10.71/api/field/830

Pin maps are not using binning, so that's why it's working.

I don't know what happen, it works right now!! anyway thanks!!
But I have a suggestion, because Taiwan is a small country, the 0.1 degree is still to large for us.

@Jay It works because it has generated a new fingerprint.
You're seeing this issue - see my comment for a possible workaround:
https://github.com/metabase/metabase/issues/12257 - upvote by clicking :+1: on the first post

OK, Git it, thanks!!