Grid map not populating

Hi, I’ve added a custom region map to my install (for Tanzania). The GeoJSON appears to load just fine in admin. However, when I build a map with that region, the map comes completely gray (see below). I’ve built maps before and it usually works just fine. Any ideas?

Hi @tjmule
Remember that you need to return a result set that matches the region identifier you selected.
If you give a link to the map, then it’s easier to help.

Yeah I think I did that! Check out the maps below (one of them works, one does not)

Kenya (sample that works – only one admin district should be highlighted) - in this example I’m using an admin3
https://dashboards.securedatakit.com/public/question/74f585a2-b2f1-49f3-b75b-2863a80fe9af
Source geoJSON: http://espen.afro.who.int/sites/default/files/content/country/maps/KE-Map.json

Tanzania (sample does not work) - in this example I’m using an admin2
https://dashboards.securedatakit.com/public/question/2e408dda-6adf-4617-bd73-385c19c7c6fb

Source geoJSON: http://espen.afro.who.int/sites/default/files/content/country/maps/TZ-Map.json

@tjmule On the Tanzania, you’re returning district_id and a number. Looking at the GeoJSON, it looks like you should then use ADMIN2ID as the region identifier.

Ya, I tried that and still no luck:

https://dashboards.securedatakit.com/public/question/2e408dda-6adf-4617-bd73-385c19c7c6fb

(worth noting that in the kenya map I called it district_id as well)

@tjmule I think you’re misunderstanding. It doesn’t matter what you call the columns of your result, but your data is:
46522 | 1
And your region_key (that’s the region identifier) is ADMIN2 instead of ADMIN2ID - you change that in Admin > Settings > Maps

OMG I’M AN IDIOT. That’s what it was. i owe you a six pack of beer. or some nachos.

https://dashboards.securedatakit.com/public/question/2e408dda-6adf-4617-bd73-385c19c7c6fb

Thank you!

1 Like

@tjmule Excellent! You’re not the only person having difficulties with how maps work, and we’ve tried to write better documentation, but it’s difficult to describe - it’s a big subject.

Yeah, FWIW the ability to easily import maps via geoJSON is a killer feature – well done to the team for having that – It works super well. And aligning the admin ids works well too (when you don’t do something dumb like I did). in the future, more map features would be great – time lapse, multiple variables, etc. I’m just now scratching the surface of what can be done with them.

thanks again!