Groups are not able to se any dashboard

Hello Community,

Problem during upgrading from .032.2 to .0.32.9
When a group member (non administrator) is trying to login, the metabase keep loading. He is not able to view any dashboard, screen keeps loading.

If i assign him admin role still some loading thing comes.
please refer to attached screen shot…

Even I tried with total new setup same issue, please help. We have same running in PRODUCTION

Getting GET /api/user/current 401 280 µs (0 DB calls)
"Unauthenticated" - IN LOGS

Hi @Sidhant
Which browser are you using?
Have you tried to use incognito-mode or clear the domain cookies?
What do you mean by “total new setup”, a new Metabase, a new browser, a new user?

Hello Flamber,

Which browser are you using? - Chrome
Have you tried to use incognito-mode or clear the domain cookies? - yes tried
What do you mean by “total new setup”, a new Metabase, a new browser, a new user? - I installed an instance of .0.32.9 on a new RHEL machine, I added the LDAP & Oracle DB successfully. Post that the loading issue is coming

@Sidhant
It sounds like something has gone wrong with the authentication.
Does this happen to all users? Do you see any browser console errors?
Just revert to your backup (or downgrade to 0.32.2, since there’s no database changes between 0.32.9).

The upgrade reason for upgrading was better download in 32.9

One thing I have noticed, if you disable the X-Ray in Admin, the loading for Administrator is coming. If you enable then the loading vanish for the Administrator.
But for the group user still loading comes…

@Sidhant
I understand the reason for upgrading, but if you’re having an issue in your production system, then downgrade until you’ve figured out the issue.

Interesting if x-rays activation is changing something, but only for Administrators.

Do you see any errors in the log?
Which backend database are you using?

DEBUG middleware.log :: GET /api/user/current 401 353 µs (0 DB calls)

DB is Oracle, as soon as I give the user as administrator every thing work fine

@Sidhant
That error just means that the user is not authenticated, so maybe you should check the log of the LDAP to make sure Metabase is connecting when authenticating.

Your backend is not Oracle, that’s your data source.
The metadata backend database is either H2, Postgres or MariaDB/MySQL.

Sorry is H2, LDAP is authenticating. It login into metabase and I can see the blue screen with loading icon from the group members

But does GET /api/user/current 401 come before you login? If yes, then you can completely ignore that. And it’s a debug log, not a warning/error.

Do you see warnings/errors in the browser console?

I would recommend that you migrate from H2 to another database for production:
https://www.metabase.com/docs/latest/operations-guide/start.html#migrating-from-using-the-h2-database-to-mysql-or-postgres

@Sidhant
Do you see this error in the browser console?
Uncaught Invariant Violation: Minified React error #143; ...

I’m almost sure that you’re getting that error - someone opened an issue about it a few hours ago:

Hey Flamber,

Absolutely getting this error, any solution or workaround for same, because of these the group members are not able to see any thing. I am forced to give them administrator permissions

@Sidhant
I haven’t been able to reproduce the issue, so I don’t know any work-arounds.
The person who created the issue said that when X-Rays was enabled, then the error was gone - that’s strange, since it’s just the opposite of what you said.
I would recommend that you downgrade to 0.32.8, since it seems like the bug started in 0.32.9

Thanks Flamber, A small help can you tell where I can find the 32.8 jar file?

We are also getting same issue, it would be very helpful if a fix is provided to this issue

If you’re using the JAR, then it would be:
https://downloads.metabase.com/v0.32.8/metabase.jar
If you’re using Docker, then the image would be:
metabase/metabase:v0.32.8

Thanks Again Flamber,

With 32.8 another issue with DB “No method in multimethod ‘connection-details->spec’ for dispatch value: :oracle”.

Do I have to change something?

Okay, so I actually found a work-around without enabling X-Rays.
If you go to Our Analytics (not from any other collection) and pin a dashboard, then it should work.

As for “No method in multimethod” - that’s an open issue since 0.32:
https://github.com/metabase/metabase/issues/9989
It should only be a problem if you restart Metabase or the database (or the database connection from Metabase). After you show a dashboard once, it will have problems loading all cards, but then it should work fine after that.