Help with Filter on Question

Hi everyone, it’s my first post here.

I don’t know if this is due to change of version or what is happening, but I am not able to filter the data I am analyzing on a question for example. If I do the same in SQL, it works as expected. I’ve been using Metabase since last year, and this is the first time that the filter worked liked this. Tried to search the internet for it, without success.

To illustrate, I took a few screenshots and posted here:

Does anyone know if this is a issue or just me being dumb?

Thanks in advance for the response!

Hi @Xukinorris
Please post “Diagnostic Info” from Admin > Troubleshooting.
I’m not sure if I understand the problem - did you click the purple button in the bottom of the sidebar, “Adicionar filtro”?

Yes, I did click on the purple button and what I got was the second screenshot.

Here it goes what you asked:

{
  "browser-info": {
    "language": "pt-BR",
    "platform": "MacIntel",
    "userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_3) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/13.0.5 Safari/605.1.15",
    "vendor": "Apple Computer, Inc."
  },
  "system-info": {
    "file.encoding": "UTF-8",
    "java.runtime.name": "OpenJDK Runtime Environment",
    "java.runtime.version": "11.0.5+10",
    "java.vendor": "AdoptOpenJDK",
    "java.vendor.url": "https://adoptopenjdk.net/",
    "java.version": "11.0.5",
    "java.vm.name": "OpenJDK 64-Bit Server VM",
    "java.vm.version": "11.0.5+10",
    "os.name": "Linux",
    "os.version": "3.10.0-1062.9.1.el7.x86_64",
    "user.language": "en",
    "user.timezone": "GMT"
  },
  "metabase-info": {
    "databases": [
      "h2",
      "mysql"
    ],
    "hosting-env": "unknown",
    "application-database": "mysql",
    "application-database-details": {
      "database": {
        "name": "MariaDB",
        "version": "10.4.11-MariaDB"
      },
      "jdbc-driver": {
        "name": "MariaDB Connector/J",
        "version": "2.5.1"
      }
    },
    "run-mode": "prod",
    "version": {
      "date": "2020-04-02",
      "tag": "v0.35.1",
      "branch": "release-0.35.x",
      "hash": "e67f169"
    },
    "settings": {
      "report-timezone": "America/Sao_Paulo"
    }
  }
}

@Xukinorris
I still don’t understand what the problem is.
Which version did you upgrade from?
Have you tried the latest version 0.35.3?
It looks like “Data Referéncia” is set as Entity in Admin > Data Model, but is that correct?