How to change the language of Metabse? I need it in English

There is no way to change the language, all the many appear in Spanish, How to change it?

Hi @Jfitch
If you’re using a version before 0.36, then language is selected based on the browser language.
If you are using 0.36.0 or newer, then you can define the language in Admin > Settings > Localization (and the user’s Account Settings).

My browser (Chrome) is setup in English, the Metabase settings are also in English, Would you please help me to see what’s happened?

@Jfitch Post “Diagnostic Info” from Admin > Troubleshooting.