How to enable custom remapping in a field?

Hello,

I’m using Metabase 0.25.2 and I’m trying to enable custom remapping but the option simply never appear. Given a numeric field I have (Postgresql integer field) I tried to:

  • set as Category
  • set as number
  • set as no special category

None of these cases the custom remapping option appeared on Display Values. The doc doesn’t mention how to use them as well.

Thanks

1 Like

So, I think I found the issue. I was trying to add custom remapping for a PostgreSQL View and the option never appear on Display Values menu. However, if I try to do the same with a table, it works no matter the type I select.

In summary, if you’re using Postgresql views, you cannot rely on custom remapping.

Reported here: https://github.com/metabase/metabase/issues/6065

just support original numeric fields?
not supper for the text type?

Yes correct, that’s currently a limitation, see:

I’m having a very similar problem, but with a MySQL database. This table is not a view. Same scenario: I can set the type to any numerical type (the original type is type/Integer) and still not receive the option to do a custom mapping. Why is this?

I have the same issue with mysql.
In my table I have different fields, some of them have the option to do a custom mapping, some of them not.
From mysql it is a type/Integer. And the conf in metabase is exactly the same for both fields.

Hi @fvafva
There’s an issue, when there are NULL values - go and upvote by clicking :+1:

Many thanks for your answer, I missed that info in github.

Im using Ver 39.1 - source database is Sqlite. Column has no null values (varchar) but is nullable. I dont seem to be able to get the custom mapping option to display

@brianwilson Metabase does currently not support mapping of strings:
https://github.com/metabase/metabase/issues/11445 - upvote by clicking :+1: on the first post