How to recover log-in credentials?

Hi! I seem to have forgotten the e-mail address I registered with or it is not being recognized for some reason during password reset. How can I continue to use Metabase? (Password reset is the only option I am offered.)

I am using Metabase locally with the Mac client (v0.24.2.0).

With the Mac app, click the Help menu item at the top of your screen, and select Reset Password.

That’s what I did before encountering the issues described in my OP.

I am being told my email address isn’t recognized and I do not see a way to recover it or register for a new account.

(I already uninstalled and reinstalled the app.)

Anything else I can do? I still have the same issue. It looks like the Desktop client is storing the expected credentials locally somewhere. Is there any way to delete them to start from scratch? I am also happy to create a new account or login, but I don’t see where that may be possible.

I could confirm in the database that I am using the correct e-mail address to log in /try password recovery with. password recovery fails, though (can’t find user).

If anyone can tell me how (what encryption to use), I could also try to fix this on DB level.

Can you try updating your Mac app to the latest (if you haven’t already) and trying again? I believe includes a fix for this issue.

I had updated to the latest version before.

In the meantime, I deleted the “metabase” database, deleted the app, downloaded again, and reinstalled the app.

I am again on a startup screen, but I am not being asked to set up a new account, but only to provide login credentials.

No new database by the name of “metabase” appears to have been created (checking with “\l” on Postgres console).

What would be steps to completely purge any trace of Metabase from my system so that I can start from scratch. Just deleting the DB and reinstalling the app does not appear to have done that. (And frankly I am not even sure, if the database was in any way related to the app-based install or from an earlierattempt of setting up a server version.)

@matt_jay Metabase keeps an internal application database in ~/Library/Application Support/Metabase. So you can exit Metabase, delete that whole directory, and then restart, and you’ll have a “fresh” instance.

1 Like

Hi there, has the location of this directory changed in the latest version of Metabase? I’m essentially experiencing the same error that was reported.

I uninstall the local version of Metabase on my mac, and upon reinstall I’m not able to see the default password setup screen. Any attempts to reset my password give me a message that the user can not be found. Thanks.

Hi @earl
Are you using the Mac App installation of Metabase or another installation (docker, JAR-file)?
If you’re using the Mac App, then location is still the same ~/Library/Application Support/Metabase/
By removing that directory, you’re resetting Metabase - meaning everything will be deleted and you’ll have a new setup.
Note that you need to close Metabase before trying to remove the directory.

I am using the MacApp installation, but the directory that you mentioned does not exist on my machine. I installed Metabase years ago and then always upgraded it. Is it possible that this folder might be in a different place from an original install? Thanks.

Looking at the documentation, I can find references to that directory since at least version 0.19.0, which is from August 2016.
You are checking your home directory, right? Since ~ in the beginning means your home directory, meaning /Users/earl/Library/Application Support/Metabase/. That would of course be different if you’re launching Metabase as a different user.