How to Remove , from Table data having Int or Long

Hi Team ,

I am new to metabase , While we write native sql query , The data which comes , if it contains Int or Long field , its automatically interpolated by adding “,” in tabular result .

04%20PM

How to remove , from the result

Hi, and welcome!

There’s already an open issue on GitHub you can :+1: vote for:

There’s also a related discussion on the whole localized display situation in Setting correct Data Format for Europe

Until the issue can get some love one workaround also mentioned in the comments is to use LPAD() and UPPER() to convert it to a string in your SQL.

An example built on the Sample Dataset:

SELECT 
  sum("PUBLIC"."PRODUCTS"."PRICE") AS "sum_original",
  lpad(upper(sum("PUBLIC"."PRODUCTS"."PRICE")), 7) AS "sum_formatted",
  "PUBLIC"."PRODUCTS"."CATEGORY" AS "CATEGORY"
FROM "PUBLIC"."PRODUCTS"
GROUP BY "PUBLIC"."PRODUCTS"."CATEGORY"
ORDER BY "PUBLIC"."PRODUCTS"."CATEGORY" ASC

Thanks @jornh , For time being i have used type casting for this . Looking forward for localize formatting .

Regards