How to set permission for db view?

I have VIEWs in my postgres database. They are visible on the list in Admin>Data Model > Data, but when I try to set permissions for them it is not possible as they are not visible on the list of tables Admin > Permissions > Data Permissions. Am I doing something wrong, or this is a bug? How to set permissions for db view?

Thanks in advance

  "browser-info": {
    "language": "pl-PL",
    "platform": "Win32",
    "userAgent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/92.0.4515.159 Safari/537.36",
    "vendor": "Google Inc."
  "system-info": {
    "file.encoding": "UTF-8",
    "": "OpenJDK Runtime Environment",
    "java.runtime.version": "11.0.11+9",
    "java.vendor": "AdoptOpenJDK",
    "java.vendor.url": "",
    "java.version": "11.0.11",
    "": "OpenJDK 64-Bit Server VM",
    "java.vm.version": "11.0.11+9",
    "": "Linux",
    "os.version": "4.15.0-136-generic",
    "user.language": "en",
    "user.timezone": "GMT"
  "metabase-info": {
    "databases": [
    "hosting-env": "unknown",
    "application-database": "postgres",
    "application-database-details": {
      "database": {
        "name": "PostgreSQL",
        "version": "11.8 (Ubuntu 11.8-1.pgdg18.04+1)"
      "jdbc-driver": {
        "name": "PostgreSQL JDBC Driver",
        "version": "42.2.18"
    "run-mode": "prod",
    "version": {
      "date": "2021-08-26",
      "tag": "v0.40.3.1",
      "branch": "release-x.40.x",
      "hash": "0550b86"
    "settings": {
      "report-timezone": "Europe/Warsaw"

Hi @michal.zielinski
A database View is just a like a Table - Metabase does not see any difference.
My first guess is that something is not synced correctly, or it might be your browser cache.
Do a manual sync via Admin > Databases > (db) > "Sync database schema now", then check the log for any errors via Admin > Troubleshooting > Logs, and then do a browser refresh and go to Admin > Permissions.