How to setup Metabase without localhost access?

I installed Metabase on remote Linux server and now I want to set it up. Unfortunately, metabase insists that I use URL “localhost:3000/setup/” to set it up. Obviously, I can’t access this URL from my browser, since it’s a remote server. If I set MB_JETTY_HOST to 0.0.0.0, it doesn’t help much, as I can’t user URL '0.0.0.0:3000/setup" either. Setting MB_JETTY_HOST to real server IP fails.

So, how do I set up Metabase in this case?

So, if I understand this correctly you’re using a remote terminal connection rather than a remote desktop tool…presumably one of those cloud services available from sites online?

If my basic understand is correct, you could technically set up the server from terminal. I haven’t tested it, but I’ve noticed that when setting it up via the browser, it posts information back to the terminal between selection of fields, so it’s likely that it uses the GUI as a middleman or wrapper with all actual functions supporting terminal input of some kind. Additionally, it’s worth noting that if your server goes through a router or other device you’ll need to port forward. Are you able to ping the real TCP IP:port?

if you look up the domain name or ip address you should be able to do

your.server.com:3000/setup” (or even “your.server.com” as that will redirect to the setup page).

Are you running this as via java -jar metabase.com or via docker image? If the former and you haven’t put nginx in front of metabase, you should be able to hit port 3000 directly unless you firewall settings are in the way. If you’re on AWS, you might not have that port open on the security group you’re using.

Can you give us a little more information regarding the setup?

Hello all!

Just now I am starting with Metabase, and I have the same problem that MaxEd. This issue is not resolved, so I want to continue, if is possible.

I am using a Raspberry running Raspbian (without a monitor) to run mysql and Database. I installed the last version of openjdk:

openjdk version “1.8.0_40-internal”
OpenJDK Runtime Environment (build 1.8.0_40-internal-b04)
OpenJDK Zero VM (build 25.40-b08, interpreted mode)

When I use “java -jar metabase.jar”, never happens (I didn’t see some log entries). I visit the address of my server (http://192.168.0.42:3000/setup), but nothing happens (I got a “ERR_CONNECTION_REFUSED” in Chrome).

Thanks for your help!
Alex.

While we’re reasonably efficient, I’m not entirely clear on how much memory/disk space we need. We also don’t explicitly support Open JDK Zero, so it’s entirely possible that is a problem.

In general, we’re relatively hefty server software, and I’d suggest running us on slightly heftier hardware. I’d suggest trying us out on configurations (eg, Mac OS X, Linux on a desktop, aws instances, etc) and once that’s working and you have some experience with it, trying it on more constrained hardward.

Thanks for your response, sameer.
Finally, I installed Java SE Development Kit 8 in Raspbian instead openjdk, using the repositories. I’am using a Raspberry Pi 3 Type B and now is working! Need 2 minutes to run, but the system is working fast, and I got some complex answers without problems. Raspberry is always interesting for a quick test.
Congrats for Metabase!
Regards!
Alex.

1 Like