How to turn off "Native JSON record support in Postgres" feature introduced recently

Since this native JSON parsing for columns has been introduced, a column JSON field has now turned into multiple columns with keys of that JSON field. For example, a column called "extra_details" had JSON records and now we have a column for each key in that column like this:

How do we turn this feature off so that instead of these multiple columns, we get only a column that we initially had, i.e "extra_details".

Thank you!

@khushi.m You can disable JSON unfolding in Admin > Databases > (db) > Show advanced options > disable "Unfold JSON columns", click "Save changes", then click "Sync database schema now".
Then you'll have to show the JSON columns, which has been hidden from normal view in Admin > Data Model > (db) > (table) > select Visibility="Everywhere" instead of "Only in details view".

1 Like