HTTP 504 after upgrading AWS EBS


I have been running Metabase on AWS EBS for quite a while now and it has been working great. I have updated to new versions by uploading the new zip and deploying it. However last successful upgrade was to 0.33 after that I haven’t been able to upgrade. All I get is a HTTP 504 error. I can roll back to 0.33 and everything works fine again.

Any ideas what could cause this behavior all of a sudden?

Hi @spiroue
So you can only run 0.33.0, and any upgrades to newer 0.33.x fails?
Without logs, it’s difficult to know what’s happening. Can you provide the logs?
Also, are you using Postgres RDS for metadata (Metabase application data)?

Thanks for a quick reply @flamber
Yes that’s correct, just tried 0.33.6 but are now back at 0.33.0

There are so many logs, where to start? :slight_smile:
Monitoring on the load balancer (classic) indicates counts on ELB 5XXs

Yes I’m using a Postgres RDS for meta/app data. (Reading on how to decouple if I need to create a new env)

But have you tried other 0.33.x releases besides 0.33.6?
I’m interested in the Metabase logs, so that would be anything related to EBS. I don’t use AWS, so don’t know where those logs are hiding.
You can read more about decoupling here: