I get an error when I create a Mysql 5.6 database connection

{:valid false, :dbname “java.sql.SQLException: Unknown system variable ‘session_track_schema’”, :message “java.sql.SQLException: Unknown system variable ‘session_track_schema’”}

Hi @qq447411944
Which version of Metabase?
While Metabase 0.32 only officially support MySQL 5.7+, it should work with 5.6
Otherwise, have you tried setting CLIENT_SESSION_TRACK=0 in the additional connection options?
For reference: https://github.com/metabase/metabase/issues/9483

The metabase version is v0.32.9.
I just tried setting CLIENT_SESSION_TRACK=0 but I still get an error.
java.sql.SQLException: Unknown system variable ‘session_track_schema’

What is the exact MySQL version you’re using? If you’re using Ali RDS, then that’s the problem.

Use Ali RDS, so how can I solve this problem?

@qq447411944 I don’t know. Upgrade to a newer MySQL version or downgrade to Metabase 0.31.2? Read issue 9483 that I linked to.

Ok, thank you for your answer. Then can I install Metabase 0.31.2 through docker?

Yes, just use the tag metabase/metabase:v0.31.2

I have solved the problem by installing Metabase 0.31.2. Thank you for your help. Is there any other tutorial that will let the old version use the configuration data of the previous version. If not, I will reconfigure it.

I already know how to do it. Thank you

how did you solve the problem? I get the same question, when I use mysql 5.6.16-log, and the metabase version 0.32.X, the same question :java.sql.SQLException: Unknown system variable ‘session_track_schema’.
how did you solve the problem?