Inconsistent SQL editing permissions

We have an odd behavior happening for only one of our users with Native query editing permissions. They are unable to see the open editor or Explore Results options in a custom sql, but I am (for the same question). They have the option to create a new custom SQL question, but are unable to type in the editor.

They have tried: two different laptops; safari, chrome, and firefox, all up to date; VPN to a different country (Canada); and recreating the user with a different email address and same Native query editing permissions.

We are on version 0.49.8.

Do they have curate permission for that question/collection?

We found a setting that for native SQL that had been changed, deep in our database structure. A really obscure permission that was removed, but no one noticed except this user. Unsure how it got removed, probably a click error. But the problem has been solved.

May I ask what this permission was? Strange how it impacted the UI

It was the database that was obscure, not the permission. You were correct, they were missing the native SQL editing permission on the database selected for the question!

1 Like