Is the DB Keepalive configurable?

I found this article :

… is the timeout described here configurable? I need to lower mine to 60 seconds if at all possible.

Not at the moment. Are your connections being dropped by a proxy or the DB itself?

The DB.

Ah, the beauty of open source. I just finished recompiling it w/ the value changed.

Glad you got it sorted.

I’m doing a bit of reading, and trying to figure out a sane value for this. Noted some thoughts in https://github.com/metabase/metabase/issues/4077 . Feel free to comment there as well =)

I think I have the same issue, but connection is being dropped by haproxy. Any hint on sane timeout config settings for haproxy with Metabase?