Issue connecting to redshift for a specific user


Strange situation for us

Redshift User 1 connects to dbeaver and metabase fine
Redshift User 2 connects to dbeaver fine - but for metabase we get this error:

The authentication type 13 is not supported. Check that you have configured the pg_hba.conf file to include the client's IP address or subnet, and that it is using an authentication scheme supported by the driver.

Redshift User 1 is the main user that has access to everything, our Redshift User 2 only has permission to one schema & table (not sure if this matters).

Wonderful if anyone has any suggestions on this?

Many thanks in advance.

"browser-info": {
"language": "en-US",
"platform": "Win32",
"userAgent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36",
"vendor": "Google Inc."
"system-info": {
"file.encoding": "UTF-8",
"": "OpenJDK Runtime Environment",
"java.runtime.version": "",
"java.vendor": "Eclipse Adoptium",
"java.vendor.url": "",
"java.version": "",
"": "OpenJDK 64-Bit Server VM",
"java.vm.version": "",
"": "Linux",
"os.version": "5.13.0-1022-aws",
"user.language": "en",
"user.timezone": "GMT"
"metabase-info": {
"databases": [
"hosting-env": "unknown",
"application-database": "mysql",
"application-database-details": {
"database": {
"name": "MySQL",
"version": "8.0.25"
"jdbc-driver": {
"name": "MariaDB Connector/J",
"version": "2.6.2"
"run-mode": "prod",
"version": {
"date": "2022-02-28",
"tag": "v0.42.2",
"branch": "release-x.42.x",
"hash": "d6ff494"
"settings": {
"report-timezone": "US/Eastern"

Hi @jazz78
I've never seen that error before, but the Redshift driver was upgraded in 0.43.0 with a couple of auth changes, so try a newer release.
There must be something specific about user2, that makes it different from user1.
Try "duplicating" user1 and see if that works, then limit the privileges. One thing at the time to see if you can figure out what is triggering it.

Hey @flamber :wave: thanks so much again as always :pray:

Yea I'm sure this is not a Metabase thing, just some error on our side on Redshift or something else, was just looking for advice, as we are stuck.

Ok will try this and report back, will first try the upgrade. thanks so much

Hi @flamber an update. did not upgrade yet, but just tried creating a new user, and now it works the message disappeared. No idea why, as far as I can tell it looks like the same user, maybe there is some different step in creating this user that i'm forgetting or not noticing. Don't know, anyway the error has gone, so we are happy. Sorry for the bother, and once again thanks for jumping in.