Issues sending mail via office365 relay

I’ve just tried setting up the email to use the office365 smtp relay (smtp.office365,com) with TLS, but when I try and send a test email I get the following error:

[WARN ] metabase.email :: Failed to send email: 530 5.7.57 SMTP; Client was not authenticated to send anonymous mail during MAIL FROM

On a side note, I discovered that if you get this same error when sending a test pulse, no error is displayed to the user.

the latter sounds like something we should add to the test email check.

mind opening an issue at github.com/metabase/metabase for us?

Have you set a from address in the email settings? If so, would you need to whitelist that address with office365?

Hi Sameer

I entered my own email address in the from field, as I know that one is already whitelisted. After doing some digging on the internet, the error usually occurs if the client doesn’t support TLS, for example if you try and use telnet - not sure if the test is using telnet to send the test email?

I’ll add the second issue to Github now.

Regards

Ben

Hmm. I’ve checked on the instances we’re running internally, and it looks like they all use SSL. Trying to verify that we have TLS working on something I can log into.

Do you of an easy to signup for email service that offers TLS? I’ll poke around, as it would be good to have one on hand to test out things like this.

Hi Sameer, Unfortunately I don’t. I did find a link to some possible resources: http://superuser.com/questions/329208/free-smtp-server-with-tls-support

Is this still an issue with you, @Ben?