JAVA_TIMEZONE and Report Timezone do nothing

Hi there, I cannot get timezones working correctly. My setup is like this:

  • Data source is redshift
  • Columns are timestamp (no tz)
  • timestamp values are UTC eg “2020-11-18 23:01:21” which would be “2020-11-19 10:01:21 AEDT”
  • Metabase is running in Elastic Beanstalk
  • Humans using the service are in Australia

No matter what I do, Metabase just shows the same time - the UTC time, and filter searches return the wrong results. I’ve tried every combination of UTC or Australia/Sydney for both JAVA_TIMEZONE and Report timezone (in settings). Literally no combination makes any difference, I receive the same result regardless.

Is there any way to fix this?

Diagnostic information:

  "browser-info": {
    "language": "en-AU",
    "platform": "MacIntel",
    "userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:83.0) Gecko/20100101 Firefox/83.0",
    "vendor": ""
  "system-info": {
    "file.encoding": "UTF-8",
    "": "OpenJDK Runtime Environment",
    "java.runtime.version": "11.0.7+10",
    "java.vendor": "AdoptOpenJDK",
    "java.vendor.url": "",
    "java.version": "11.0.7",
    "": "OpenJDK 64-Bit Server VM",
    "java.vm.version": "11.0.7+10",
    "": "Linux",
    "os.version": "4.14.158-101.185.amzn1.x86_64",
    "user.language": "en",
    "user.timezone": "Australia/Sydney"
  "metabase-info": {
    "databases": [
    "hosting-env": "elastic-beanstalk",
    "application-database": "postgres",
    "application-database-details": {
      "database": {
        "name": "PostgreSQL",
        "version": "11.8"
      "jdbc-driver": {
        "name": "PostgreSQL JDBC Driver",
        "version": "42.2.8"
    "run-mode": "prod",
    "version": {
      "date": "2020-11-16",
      "tag": "v0.37.2",
      "branch": "release-x.37.x",
      "hash": "25e5f70"
    "settings": {
      "report-timezone": "Australia/Sydney"

Nothing funny in the logs that I can see,

 {"file.encoding" "UTF-8",
 "" "OpenJDK Runtime Environment",
 "java.runtime.version" "11.0.7+10",
 "java.vendor" "AdoptOpenJDK",
 "java.vendor.url" "",
 "java.version" "11.0.7",
 "" "OpenJDK 64-Bit Server VM",
 "java.vm.version" "11.0.7+10",
 "" "Linux",
 "os.version" "4.14.158-101.185.amzn1.x86_64",
 "user.language" "en",
 "user.timezone" "Australia/Sydney"}

Hi @wghm
Sounds like you’re seeing this issue: - upvote by clicking :+1: on the first post