Line showing on scatter graphics

Browser: latest Chrome
OS: Windows 10 x64 Pro updated
Type of DB: Postgres
Metabase version: v0.39.4
Hosting environment: Heroku

Repeatable steps to reproduce the error: I'm not sure, yesterday I selected the type "Line", then played a bit with the Line Style/Color options, and when I switched to "Scatter" the line I played with didn't change to a bubble:

After this, I tried to change back to other forms, saved, and changed back to scatter but the line persisted. I tried to replicate the problem with the dataset provided by Metabase without success. I even tried to replicate it with the same steps that I did yesterday on the same DB and data, but this time the line changed to a bubble when choosing "Scatter". I just wanted to report this for further investigation, although I know not being able to replicate the error will make this harder: no errors in JS console whatsoever, and the error persisted on other browsers as well (latest version of Firefox Developer Edition)

EDIT: adding this info as well: in settings, it's possible to choose the Line type/Color for that parameter (while being in Scatter mode), whereas I don't have the option for the other parameters:


Hi @MC23
You are seeing this issue, which causes some of the settings to be preserved, when switching to Scatter - upvote by clicking :+1: on the first post

Ok, I already read that before posting it but I didn't understand it was the same error. I upvoted it :>

@MC23 It's not really the exact issue, but more generally, so understand why it confused you. Creating an issue for every single setting would make it impossible to overview anything in the tracker. The core problem is that Scatter is not the same as Line/Bar/Area/Combo, so we need to drop anything that isn't applicable to Scatter.