Logs keeps on loading

i have recently updated metabase to v1.40.7 to deal with the log4j vulnerability. but since then the logs module in troubleshooting keeps on loading, i also tried upgrading log4j to v 2.15.0 manually and had the same result.

this is my Diagnostic Info :
"browser-info": {
"language": "en-US",
"platform": "Win32",
"userAgent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/96.0.4664.110 Safari/537.36",
"vendor": "Google Inc."
"system-info": {
"file.encoding": "Cp1252",
"java.runtime.name": "Java(TM) SE Runtime Environment",
"java.runtime.version": "1.8.0_211-b12",
"java.vendor": "Oracle Corporation",
"java.vendor.url": "http://java.oracle.com/",
"java.version": "1.8.0_211",
"java.vm.name": "Java HotSpot(TM) 64-Bit Server VM",
"java.vm.version": "25.211-b12",
"os.name": "Windows Server 2016",
"os.version": "10.0",
"user.language": "en",
"user.timezone": "UTC"
"metabase-info": {
"databases": [
"hosting-env": "unknown",
"application-database": "postgres",
"application-database-details": {
"database": {
"name": "PostgreSQL",
"version": "11.3"
"jdbc-driver": {
"name": "PostgreSQL JDBC Driver",
"version": "42.2.18"
"run-mode": "prod",
"version": {
"tag": "v1.40.7",
"date": "2021-12-10",
"branch": "release-x.40.x",
"hash": "07fdc71"
"settings": {
"report-timezone": null

Hi @Chetan
Upgrade to Java 11: https://www.metabase.com/docs/latest/operations-guide/java-versions.html

1 Like

Thanks @flamber


I am facing same problem, but after upgrading to Java 11 and restarting services problem persists. @flamber
Metabase version "v0.41.5"

@mgf Post "Diagnostic Info" from Admin > Troubleshooting. You should upgrade to a newer release.