Making metabase_files private stops images from being posted


So We are pushing confidential information from metabase to private channels that only select people in the company can see. We made the metabase_files channel private and this stopped the image of the pulse from showing. It is only showing the link to the table/graph.

Does metabase_files need to public? Is there a work around where the confidential information can be sent via pulse and not have it store in metabase_files?


Hi @VinayakK, unfortunately this is a limitation of Slack rather than ours. Please check this article

and this discussion over Github as well:

best regards,

By the way, I suggest you switch to email pulses if you need to push confidential information. You can push pulses to group emails where you can control the access to them.

1 Like

ok thanks! I gotta check in with the people who want it to be private and see if they are ok with emails.


I made another mistake. I renamed the private metabase_files channel to something else and and a new metabase_files public channel. The problem is now only the link is being posted and the file is not even storing in the new metabase_files channel.

What can I do to fix this?

Hi @VinayakK, I’m sure that the Slack API is sending the files to the previous channel, do you have any way of reverting changes?

So I left it alone for a couple hours and it works now! I did not make anymore changes than what I said before.

Weird but I not going to touch is again until it breaks.


@VinayakK If you had restarted Metabase, then it would have worked instantly, but otherwise it caches it for 6 hours, so Metabase doesn’t hit the Slack API constantly.

1 Like