Metabase Actions doesn't work in Public Dashboards

Good morning,
I would like to setup a end-user serviceable dashboard where a user does not need an email in order to make actions.

For some reasons using the action in the Metabase app works however the embed version comes up with the action button greyed out. Why would this be happening and how can I enable it?

If this is not possible would you please direct me on how to setup users so that they can login via LDAP auth. I have set this up but putting the correct password just says "failed"

have you enabled actions for that database? to enable actions go to settings->admin->databases

Greetings Luigi, I am facing the exact same problem. To answer your question, yes I have enabled actions for the database in admin settings as I am able to to make the action work properly in the Metabase app. The problem still remains in the embedded Metabase. If you read carefully, he said "For some reasons using the action in the Metabase app works however the embed version comes up with the action button greyed out. "

Appologies. I completely forgot to answer your question! I must have missed the email notification.
Yes as said by @eddysaidin8 I have also enabled.

It would not have been possible for me to make the action in the first place without it being enabled.

The action does still work when a user logs in.

But we have no way of sending emails to our users which also have no way of accessing emails so there are no logins for Metabase for these people.

We have updated recently our metabase and moved to docker however not it seems like the database dashboard has vanished and I am unable to change if actions are enabled or disabled.

Hi all,

I have the same problem today : in an embedded dashboard, actions don't work (and work perfectly in Metabase app).
Here the message :

Is there a solution or still not ?

Best regards,

No one knows if it's possible to use CRUD in an embedded dashboard inside an other web site ?

Is there a solution to the problem?

I went home and setup a docker container that had Metabase on it (this was a separate instance). When I run it actions worked fine. When I connected it to our Metabase database it had the same issue. So, I am thinking that it is the database that is missing something. Possibly when migrating?

So, we have decided to end up creating a separate bespoke system separate from Metabase which is able to do this for us instead. It's quite a simple task. Metabase has painfully slow loading times anyways with our dashboards.

Same question. Is there any new solutions?