Metabase: Activate Enterprise Edition (ON) HTTPS Port 443

Hello people good night!

By huge favor, how do I enable Metabase to be able to access outgoing connections on HTTPS port 443? Here in the company, if I can not do this, we will not be able to use Metabase because I need the SAML Authentication feature, which is available only in the ENTERPRISE edition of METABASE. Please someone help me?


Metabase only make a few outgoing connections - among other for Slack. That’s already using TLS/SSL. There shouldn’t be any outgoing connections that are not using secure protocols. (there’s an outgoing proxy issue)
Connections to databases are controlled by the options you define in the settings.

If you’re talking incoming connections needs to be https, then you need a certificate and either setup reverse proxy or Jetty to handle that.

Hi, @flamber

I need to activate a token that will release the enterprise features of Metabase. According to Cam Saul, from Metabase, that port 443 needs to be released in the JVM through the proxy. I’m using the commands (java -DproxySet = true -DproxyHost = -DproxyPort = 443 -jar metabase.jar), but java returns the error (Error: Could not locate or load main class .0.0.1) . How to solve this problem?

With the command below, Metabase started:
java -DproxySet = true -DproxyHost = -DproxyPort = 443 -jar. \ enterprise_metabase.jar

But when you try to activate the token, you returned the error below: Connection refused: connect

How to fix this?


Okay, so you are using “outgoing proxy”. Is that correct? Try launching like this:

 java -Dhttps.proxyHost= -Dhttps.proxyPort=443 -Dhttp.proxyHost= -Dhttp.proxyPort=443 -jar enterprise_metabase.jar

Are you sure your proxy is located on, which is localhost, which means your proxy server is on the same machine as Metabase.

@camsaul @sameer How is support handled for Enterprise features like this?


Executando o comando sugerido, ocorreu o erro:

“Output of fetch-token-status* does not match schema: \n\n\t e[0;33m {:status (not (instance? java.lang.String a-metabase.util.i18n.UserLocalizedString)), :error-details (not (instance? java.lang.String a-metabase.util.i18n.UserLocalizedString))} e[0m \n\n”,
:value {:valid false, :status “Unable to validate token”, :error-details “ValidaþÒo do token demorou demais.”},
:error {:status (not (instance? java.lang.String a-metabase.util.i18n.UserLocalizedString)), :error-details (not (instance? java.lang.String a-metabase.util.i18n.UserLocalizedString))}}


The Ideal would be, if in the settings of the Metabase, had a place to configure the proxy and etc, for this type of situation. I am forcing this configuration directly into the JVM and it is not working … I did a token check directly on the browser and it will be valid until 04/14/2019 and I have not yet been able to activate the Metabase Enterprise edition for testing. What do I do?

I don’t know, since I don’t have Enterprise edition, so I would recommend that you send a message via the contact form:


OK thank you! I will proceed with your suggestion.