Metabase and Postgres ROLLBACK

We are running a few metabase dashboards frequently and the same (expensive) queries are running very frequently on the backend (redshift). So I put a pgpool frontend to redshift to cache query results and connected metabase to it (as Postgresql). But it seems like metabase is issuing a ROLLBACK command after each query which prevents pgpool from correctly caching the query results. Why is this happening? Can I disable it?

I ended up finding the metabase caching and turned that on – it really helped to lower the load on my backend database.

Glad to hear that!