Metabase API - Any change on authentication lately? 403

Hello! I had a python script that was running fine until at least Dec 13, 2021. Now, I'm not able to authenticate, I receive an error while getting the session_id (it is empty) and then when I check what all the "response" is getting, I receive a <Response[403]>. I tried searching for an answer online but nothing worked.
For instance, I'm using the same initial code structure as it can be found here:

response ='http://localhost:3000/api/session',
                         json={'username': '',
                               'password': 'database1'})
session_id = response.json()['id']
headers = {'X-Metabase-Session': session_id} 

I double checked and the user is still an admin etc. Did we have any change on this lately?

My metabase version is 0.40.5


Hi @metauser42
You should upgrade immediately to latest release:
If your API doesn't work, then the GUI wouldn't work either.

Tks for the reply, flamber!

The GUI works as usual, but API has this problem. I'm not able to easily upgrade it right now, is there anything I could do to get the API working as last month?

@metauser42 Let me just outline how important the upgrade is:

If you use the GUI, then use your browser developer Network-tab to see what is being sent.
The Metabase GUI just uses API, so if something works in GUI, then the API also works.

But I have no idea if the host, port, username or password is correct, but the 403 error means forbidden:

Tks, flamber! I'm programming to do the update asap.

I really appreciate your help and attention!