Metabase build

hello, i’mtrying tobuild metabase but i always get this error:
build : line 5: ./bin/version no such file or directory…
can you help me ?

@mohamed what OS are you trying to do the build on?

I’ve experienced something similar on Win10 when mixing line endings across Windows and Ubuntu on Windows aka WSL (CRLF vs LF).

yes i am, what can i do to fix the problem ?

On way is to run the file through dos2unix … another is to not mix tools across the two OS’es e.g. don’t do a Windows git checkout and then run the build script in bash on the Unix side.

i’m using ubuntu on virtualbox

Ah OK, not the problem I ran into then.

So, please share details on:

  • from what working dir are you trying to run the build?
  • what is the output of ls -la ./bin/ there?
  • do the user you run the build as have proper execution permissions?

I need you to try harder to help me to to help you.

when i run the build i place myself in the bin directoey, but i hava to change every directory inside the build for example instead of ./bin/version i have to change it to /home/mohamed/Downloads/metabase-master/bin/version otherwise it won’t work. the probleme i’m facing now is related to the webpack this message keeps showing : no configuration file found and no output filename configured via CLI option.a configuration dile could be named “webpack.config.js” in the current directory

I invoke the build as ./bin/build from the project root so in your case that would match /home/mohamed/Downloads/metabase-master

Regarding your webpack problem that could easily be related. If it still fails then maybe a good idea to try running from a fresh git clone if you realize you took a wrong turn to make sure you are not tripped up by some inconsistencies.

thank you one finalquestion where is the webpack configuration file is it the one in metabase-master/webpack.config.js ?

Yes this one

if it’s that one, why is this line exist in the build file : NODE_ENV=production ./node_modules/.bin/webpack is this another webpack configuration file. eventhough i doubt that since it always gives me the message that this isn’t a configuration file