Metabase built with AWS Elastic Beanstalk can no longer connect

I used ElasticBeantalk to build Metabase.
The referenced RDS is Mysql.
About one month after the construction, the following error occurred and the data could not be referenced.

Socket fail to connect to host:rds-endpoint, port: 3306. No route to host (Host unreachable)

I have not changed the security group settings.
I'm not using an SSH connection.
The referenced RDS is a read replica.
You can connect to Primary from Metabase (EC2) with the mysql command,
The read replica will result in an error.

ERROR 2003 (HY000): Can't connect to MySQL server on'' (113)

I can't figure out what's causing it.

Diagnostic Info

  "browser-info": {
    "language": "ja",
    "platform": "Win32",
    "userAgent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/99.0.4844.51 Safari/537.36",
    "vendor": "Google Inc."
  "system-info": {
    "file.encoding": "UTF-8",
    "": "OpenJDK Runtime Environment",
    "java.runtime.version": "",
    "java.vendor": "Eclipse Adoptium",
    "java.vendor.url": "",
    "java.version": "",
    "": "OpenJDK 64-Bit Server VM",
    "java.vm.version": "",
    "": "Linux",
    "os.version": "4.14.262-200.489.amzn2.x86_64",
    "user.language": "en",
    "user.timezone": "GMT"
  "metabase-info": {
    "databases": [
    "hosting-env": "unknown",
    "application-database": "mysql",
    "application-database-details": {
      "database": {
        "name": "MySQL",
        "version": "8.0.23"
      "jdbc-driver": {
        "name": "MariaDB Connector/J",
        "version": "2.6.2"
    "run-mode": "prod",
    "version": {
      "date": "2022-02-28",
      "tag": "v0.42.2",
      "branch": "release-x.42.x",
      "hash": "d6ff494"
    "settings": {
      "report-timezone": null

Thank you for looking at the question

Hi @kousuke
So you are having problems with a data source (Admin > Databases)?
The error "No route to host (Host unreachable)" hints at networking problems - normally DNS or firewalls (or security groups).
Something was perhaps now allowed originally, but Metabase was using the primary for the first month.
Try restarting Metabase.