Metabase crashing after few days of uptime


We are running Metabase on EC2 instance from official Docker container, with configuration outside of it. It is relatively small instance 1GB RAM, 1 CPU, but we do have 1 user only.

My problem is it continuously crashes after few days of uptime. I tried to save logs, to trace what the problem might be, but logs stops working few days before it crashes.

Any idea what might be the problem and how to resolve it ? Thanks in advance

Hi @dj.dule

Please post “Diagnostic Info” from Admin > Troubleshooting.

I’ve never heard of the logs stopping and then Metabase continues to work for a few days before it crashes. Sounds like you might be running out of disk space.

Where are you getting the logs from? docker logs ?

The specs doesn’t tell a lot. You could have a massive database source, which means that Metabase would have to index a lot more metadata. Or the single user could have created thousands of questions and using Pulses for a lot of them. Or maybe a question is publicly shared, and visited by thousands of visitors each days.
This is why it’s really hard to give recommendations on specs, since it’s depends on data and usage.

I do not think it is a disk issue, since there is around 32GB free.

I was catching the logs using
docker logs -f metabase > metabase.log &

Database that we are looking into is small accounting database, with around 15 reports, so I doubt it is performance issue.

Any other idea how to try to debug this ?

Here is asked info:

“browser-info”: {
“language”: “en-US”,
“platform”: “MacIntel”,
“userAgent”: “Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:77.0) Gecko/20100101 Firefox/77.0”,
“vendor”: “”
“system-info”: {
“file.encoding”: “UTF-8”,
“”: “OpenJDK Runtime Environment”,
“java.runtime.version”: “11.0.7+10”,
“java.vendor”: “AdoptOpenJDK”,
“java.vendor.url”: “”,
“java.version”: “11.0.7”,
“”: “OpenJDK 64-Bit Server VM”,
“java.vm.version”: “11.0.7+10”,
“”: “Linux”,
“os.version”: “5.3.0-1023-aws”,
“user.language”: “en”,
“user.timezone”: “GMT”
“metabase-info”: {
“databases”: [
“hosting-env”: “unknown”,
“application-database”: “h2”,
“application-database-details”: {
“database”: {
“name”: “H2”,
“version”: “1.4.197 (2018-03-18)”
“jdbc-driver”: {
“name”: “H2 JDBC Driver”,
“version”: “1.4.197 (2018-03-18)”
“run-mode”: “prod”,
“version”: {
“date”: “2020-05-28”,
“tag”: “v0.35.4”,
“branch”: “release-0.35.x”,
“hash”: “b3080fa”
“settings”: {
“report-timezone”: null

To begin with, migrate away from H2:

Seems like it’s a problem with Docker logs follow-parameter:
You should probably look into a different way of logging Docker.