Metabase go back to screen setup


Yesterday my datacenter go down and the virtual machine when runs metabase too. When i started the virtual machine, the page metabase go to screen setup. How can fix this?

Hi @brunocampos87
Without knowing where you have the Metabase application database or how you were running Metabase, then it's difficult to say, but make sure you have pointed to a persistent place:
Configuring the Metabase application database

Thanks Flamber for your answer.

I discover part of the problem, the metabase was running and the port 3000 was ocupped

I kill the process and run the command :jack_o_lantern:

java -jar metabase.jar

Metabase up again, BUT, the dashboard disappear and others connections like postgres database too

How can recover this?

Thank you so much!

@brunocampos87 So you have never migrated away from using H2 as the application database?
Then there's a somewhere else on your system (unless you lost that during the crash).
You need to find the H2 and then you need to migrate away from it:

I never migrate.

The file are in the same path like others files metabase.dbtrace.db, metabase.jar, one folder "plugins"

The path is /opt/metabase/...

This is my scenario:

"browser-info": {
"language": "pt-BR",
"platform": "Linux x86_64",
"userAgent": "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36",
"vendor": "Google Inc."
"system-info": {
"file.encoding": "UTF-8",
"": "OpenJDK Runtime Environment",
"java.runtime.version": "11.0.12+7",
"java.vendor": "Eclipse Foundation",
"java.vendor.url": "",
"java.version": "11.0.12",
"": "OpenJDK 64-Bit Server VM",
"java.vm.version": "11.0.12+7",
"": "Linux",
"os.version": "4.4.0-210-generic",
"user.language": "en",
"user.timezone": "America/Recife"
"metabase-info": {
"databases": [
"hosting-env": "unknown",
"application-database": "h2",
"application-database-details": {
"database": {
"name": "H2",
"version": "1.4.197 (2018-03-18)"
"jdbc-driver": {
"name": "H2 JDBC Driver",
"version": "1.4.197 (2018-03-18)"
"run-mode": "prod",
"version": {
"date": "2021-08-26",
"tag": "v0.40.3.1",
"branch": "release-x.40.x",
"hash": "0550b86"
"settings": {
"report-timezone": null


  1. You need to upgrade immediately to a newer release:
  2. Then you need to figure out where the other H2 is located. I cannot tell you that. Try searching your system.
  3. Then you need to migrate away from H2

Ok. I will upgrade in next days

Now, i have a doubt

I went to metabase database and in table SETTINGS have a configuration of my client e-mail, but it no applied in the metabase service mail, understood?

What do you think about it?

@brunocampos87 I don't understand what you are talking about. You need to configure the place where Metabase stores all its information (which is called "Metabase application database" or "application database" or "AppDB" in our documentation).
If you don't configure anything, then it uses H2 by default.

Please read through and

If you are unsure how to install and manage hosting, then there's Metabase Cloud:

Friend! Works! I l learned that i need to export name and password of mysql and my metabase.db.

Only this! Thnx