Metabase idle tab crash?

Hey guys,

I don’t know if i’m in the right place; if not I apologize; onward.

So I have a fresh install of metabase (with jdk8) and when visiting the site, all appears to work fine, I’ll leave the tab open, and come back – to a whitescreen and unresponsive on the tab; I thought it might just be a pie graph or report in the wild, but it happened at the “dashboard” screen as well. (which has no reports or anything on there yet)

In addition, when I try to use the “sorting” option, (the … drop down on a question) – it locks up, and ultimately goes to the same whitescreen.

I really like the product, and was hoping to resolve these small quirks preventing me from populating this fully.

Any feedback would be appreciated.

I ran into this as well. Check to see if your machine maxing out memory usage.

I’m was running Metabase on a Digital Ocean server with 512MB of RAM and that was not nearly enough. I’m now using a 2GB droplet and it’s running nicely. I would recommend that your host machine have at least 2GB or RAM.

Here’s a chart of my server’s RAM usage(Ubuntu 14.04). Before June 30th I tried 512MB and 1GB droplets and they did not run well.

The machine in question has 2 CPU’s and 7.5GB of ram…

Doesn’t seem to be any way from a quick overview in raising memory thresholds; any other thoughts would be greatly appreciated :o)

Sorting is definitely broken and I reported it yesterday:
https://github.com/metabase/metabase/issues/2859

If the screen goes blank in any other situation you should check the log for any errors. You should also check for errors in the browser’s developer console which can usually be access by hitting f12 on your keyboard(don’t know if it’s the same for Mac)

What browser version + OS are you using?

It sounds like the problem is with the front end client, not the server by your description.

@sameer FYI I’m having server side problems right now and I’ve got a blank white page in the browser.

Hey guys, I tried in both chrome & firefox – latest versions.

Is there any other? :wink: – I tease, so it seems someone else is experiencing this; I was thinking it may be a configurational thing, but I couldn’t really find anyway to tweak the configurational settings (other then a few path vars).

Maybe it’s relevant, maybe not, but some of my DB servers are in another NOC

Edit: OS is windows 10 & ubuntu

what’s in the server logs?

I haven’t had a chance to tinker with it since the report; and unfortunately my developer who set it up routed the logs to /dev/null :stuck_out_tongue_winking_eye:

I’ll be digging into it further this weekend – and I’ll post further info here.

I do very much appreciate the followup, and apologize for the delay on the server-logs.

Super excited about getting this running proper though !

Gotcha. The logs would be pretty useful =)

Absolutely; just as soon as I start tinkering, i’ll replicate and post over here. Once again, appreciate the followup!

If I don’t post tonight it’ll be tomorrow – (holidays+kids, get in the way of work :slight_smile: )

Thanks once more, post soon, take care over there!

Alright, so i’m a little slow :o)

Here is what happens in Chrome/Firefox when selecting a sort field: http://screencast.com/t/r5SoWwVN5Kan

The console exports this, and it continues to increment the number you see to the left of “Unknown field format undefined”

The metabase.jar on CLI outputs nothing

Edit: seems it’s already been reported: https://github.com/metabase/metabase/issues/2859