Metabase is launching child process

I am new to metabase and assigned 2G as minimum heap size and 4G as maximum heap size. When I run ps -aux | grep java it shows me metabase is running with given heap size. But periodically metabase launch another process with heap size of 128M (min) and 512M (max)

I am not sure from where its launching new process and why its taking 128M & 512M

Any help or suggestion would be appreciated.


Hi @gaurav.sharma1
When you say “periodically”, what does that mean? And does the child process stay around or close after a period?
Could it fit with the synchronization or pulses?
You should be able to see something in the log - does anything match with the periodical process?

Hi flamber,

Thanks periodically means after every couple of minutes it starts a new process with heap size of 128M & 512 M and after sometime automatically this process got finished.

Yes it might be synchronisation but my doubt is why its taking heap size of 128M and 512 M . Can i control this heap size.

I think you might be seeing the Jetty threads. Try using htop and Filter by metabase and Tree view.

When I run following command

ps -aux | grep java

ubuntu 19405 0.8 29.5 8010328 4720096 ? Sl Mar04 10:21 /usr/bin/java -Xms4g -jar metabase.jar
ubuntu 30372 294 1.9 3083192 312460 ? Ssl 04:28 0:11 /usr/bin/java -Xms128m -Xmx512m -jar metabase.jar

There are two instances of metabase.jar are running one started on Mar04 10:21 AM while other got started just before checking the process.

Okay, it seems like you’re starting Metabase twice. It doesn’t look like you’re running it as a service, so I’m unsure how it starts twice.