Metabase password true but cannot access metabase

I have a problem when logging into the local metabase, the password is never changed forever. I accessed the metabase yesterday with the same username and password without modifying the comment server, but when I want to access it again in the morning, I can't login to the metabase.

please need help

Hi @fakhri
Metabase does not change the logins by itself, so something must have changed.
Have a look here:

Thanks for your answer

I have tried the tutorial "Do you need to reset the admin password?" but when the service is run the token page is invalid and requires repeating while I haven't done anything on the page

@fakhri Okay, I don't know which version you're using, but make sure it's up to date:

I can guarantee you that Metabase does not automatically change logins. There's no such code.

I am using metabase version v0.39.1
can i still login when updating update ?
requires me to reset the password like the previous tutorial?

@fakhri You should upgrade immediately:

I have a few more questions

do you know some of these error messages?

ERROR metabase.core :: Metabase Initialization FAILED clojure.lang.ExceptionInfo: Unable to connect to Metabase h2 DB. {}
at metabase.core.main(Unknown Source)
Caused by: org.h2.jdbc.JdbcSQLException: Database may be already in use: null. Possible solutions: close all other connection(s); use the server mode [90020-197]
Caused by: java.lang.IllegalStateException: The file is locked: nio:/opt/metabase/ [1.4.197/7]

@fakhri Yes, there's another process locking the H2 file. The Linux command lsof can help you seeing which processes are locking files. Remember to shutdown everything before trying to update. And you have of course remembered to do a backup first.

You should migrate away from H2 if you are using Metabase in production:

And make sure you are using the latest Java 11:


for error "Metabase Initialization FAILED Failed to bind to Caused by: Address already in use"

I'm reading this because port 3000 is already in use, but when I check the PID it's using is java

I tried removing and running "java -jar metabase.jar" the result is still the same.

@fakhri That's likely because you set it up as a service initially. Figure out how you installed Metabase.

I don't know your setup, but I would probably recommend that you consider switching to Metabase Cloud if you want someone else to manage hosting.



I tried again running the password reset command, and what appears in my console is something like this.
the display on the page shows an error

@fakhri You will always see "Unauthenticated", since you're not logged in. Make sure that your server time is actually correct.


I make sure the date and time settings are correct

@fakhri I don't know what is wrong with your setup, but I would recommend that you make a completely new setup or move to Metabase Cloud.

It's weird as I have the exact same issue on my self hosted server. I was able to login to metabase fine until two weeks ago with the password that I have.
After that, I hadn't opened metabase and then now, I am unable to login anymore!

I have checked my password manager and I ever had only one password for it which I know was working before.
I will try to do the steps you've mentioned but the same issue in two unrelated situations may be worth looking in to.

@johnny So if you are also using a version that has known vulnerabilities to Log4j (read any news from December), then it's quite possible that someone else has gotten access and changed things.

There's more than 40,000 Metabase setups, with unknown amount of users, but millions, so that two people encounter the similar problems is likely, but that it's the same problem and an actual bug in Metabase, that I don't think.