Metabase pulses/alerts and British Summer Time

Hi there,

We're having an issue with metabase reports and British summer time. GMT+1 UTC+1 etc.

We have a report set to send daily at 3pm which is coming in at 4pm since British summer time began.

I tried to fix it by setting the TZ environmental variable to europe/London but it's still an hour out.

SendGrid is saying it received the notification to send the email at 3pm UTC-0 which would be 4pm UTC+1 so the issue must be with metabase.

Our server is returning the current UTC+1 time when I run date on it (though i'm not able to get it to tell me which timezone its in as timedatectl wont run on the dyno)

any help is greatly appreciated as we have some reports needed at 9am and don't want to remember to manually change the time they're set up for twice a year!

Hi @hnfg

Post "Diagnostic Info" from Admin > Troubleshooting.

The timezones comes from Java, which partially gets its information from the OS, so making sure that the OS tz_data and Java is up-to-date is crucial.

ah ok hopefully its something as simple as that!

  "browser-info": {
    "language": "en-GB",
    "platform": "MacIntel",
    "userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/100.0.4896.127 Safari/537.36",
    "vendor": "Google Inc."
  "system-info": {
    "file.encoding": "UTF-8",
    "": "OpenJDK Runtime Environment",
    "java.runtime.version": "1.8.0_332-heroku-b09",
    "java.vendor": "Oracle Corporation",
    "java.vendor.url": "",
    "java.version": "1.8.0_332-heroku",
    "": "OpenJDK 64-Bit Server VM",
    "java.vm.version": "25.332-b09",
    "": "Linux",
    "os.version": "4.4.0-1101-aws",
    "user.language": "en",
    "user.timezone": "Europe/London"
  "metabase-info": {
    "databases": [
    "hosting-env": "heroku",
    "application-database": "postgres",
    "application-database-details": {
      "database": {
        "name": "PostgreSQL",
        "version": "13.6 (Ubuntu 13.6-1.pgdg20.04+1+b1)"
      "jdbc-driver": {
        "name": "PostgreSQL JDBC Driver",
        "version": "42.2.23"
    "run-mode": "prod",
    "version": {
      "tag": "v0.42.4",
      "date": "2022-04-07",
      "branch": "release-x.42.x",
      "hash": "7c3ce2d"
    "settings": {
      "report-timezone": "GMT"

I have 4 servers running in the UK. Mixture of Docker, Windows and Linux. All sending alerts at the correct time.
They all the
"settings": {
"report-timezone": "Europe/London"

You have GMT

1 Like

@hnfg As Andrew points out, you should set the Admin > Settings > Localization > Report Timezone

I've made that change :crossed_fingers: hopefully my test report comes through at 10am!

I did change the report timezone previously. The wording for that option had me thinking it was to do with the data in the report not the time the report comes out.

That's timezones for you! Just be glad that you're in the UK!

it worked! Thank you everyone :slight_smile:

Timezones just instantly make my brain decide not to cooperate!