Metabase Upgrade wants a Postgres Database Regression

I using AWS Elastic Beanstalk to run Metabase and it uses a RDS Postgres instance as a database.
The current version I’m using is 0.33.3 and would like to upgrade to 0.35.3.

Problem I’m having is that the update process fails with:
Updating RDS database named: ******** failed Reason: Cannot upgrade postgres from 10.11 to 10.6

It appears that the new versions of Metabase enforces Postgres engine 10.6, while the older version 0.33.3 runs fine on Postgres engine version 10.11. I’m able to redeploy Metabase 0.33.3 with Postgres 10.11 multiple times without any issues.

The only thing I can think of is creating a database dump and restoring it to an older Postgres engine 10.06 and then retry the upgrade process.

Is there any other advise? Thanks in advance.

After more digging, I found out that the current install is actually Metabase 0.33.0 and not 0.33.3. Trying to update from 0.33.0 to the real 0.33.3 still causes same error though. Trying to upgrade to 0.33.1 also causes the same error.

Hi @noodle_wave
Metabase does not upgrade your RDS Postgres. This is probably something to do with the EBS environment that is causing that. Try contacting AWS support.
For reference: