Metbase Killed

Hi All,

I am very new to Metabase, I have mysql database with more than 500 tables and I want analyze mysql Database using Metabase.

System Information:
Ubuntu 16.04.3 LTS
mysql Ver 15.1 Distrib 10.2.12-MariaDB
I hosted my web software on cloud.

Issue Detail:
I have installed Metabase successfully but now while running metabase using java -Xms256m -Xmx512m -jar ~/frappe-bench/apps/tablix/metabase/metabase.jar

It’s showing me this output:

02-10 11:39:12 INFO metabase.util :: Loading Metabase...
./install: line 3:  2786 Killed                  java -Xms256m -Xmx512m -jar metabase/metabase.jar

I think this is conflicted with my Web server database, because If I try after shutdown my website its working fine but its not working while my website is also running.

Please help me sort out this issue.

You can try telling metabase to serve on another port by setting an environment variable. The documentation states:

You can use another port than 3000 by setting the MB_JETTY_PORT environment variable before running the jar

My run script has this line:

export MB_JETTY_PORT=3030


Thanks for your response.

I already tried it.
I just created bash file to try so and it’s running on same port number which is 5050.

Please see this code for more information:

#! /bin/bash
export MB_JETTY_PORT=5050
java -Xms256m -Xmx512m -jar ~/frappe-bench/apps/tablix/metabase/metabase.jar 

But still getting same error


It must be something even more fundamental with your environment than the web server port. Because it dies shortly after logging this even before it even logs that it’s starting the Jetty web server. Maybe memory/disk or other resource constraints?

@navdeepghai what’s the output of free -h when your other web application is running, and what’s it when the other one is not running (where you said Metabase worked OK?). Also what’s the output of java -version? Does a copy of the exact same Metabase.jar work on another machine?

Thanks for your response.


free - h

              total        used        free      shared  buff/cache   available
Mem:           2.0G        1.3G         68M         38M        577M        397M
Swap:            0B          0B          0B

java -version

openjdk version "9-internal"
OpenJDK Runtime Environment (build 9-internal+0-2016-04-14-195246.buildd.src)
OpenJDK 64-Bit Server VM (build 9-internal+0-2016-04-14-195246.buildd.src, mixed mode)


Revised Output:

If there is not service running on My Server then output for free -h is :slight_smile:

free -h
              total        used        free      shared  buff/cache   available
Mem:           2.0G        572M        1.0G         38M        393M        1.2G

If metabase is running then:

free -h
              total        used        free      shared  buff/cache   available
Mem:           2.0G        1.2G        330M         38M        393M        508M
Swap:            0B          0B          0B

Now Metabase is stopped and My web server is running:

free -h
              total        used        free      shared  buff/cache   available
Mem:           2.0G        1.3G         96M         38M        528M        376M
Swap:            0B          0B          0B

Just started Metabase along with web server then output is:

free -h
              total        used        free      shared  buff/cache   available
Mem:           2.0G        1.8G         54M         38M        134M         16M
Swap:            0B          0B          0B

But I am not able to get to peak value of memory usage when both applications are running because when I ran metabase along with my server after few minutes metabase service got killed before reaching to peak value.


Q: Does a copy of the exact same metabase.jar work on another machine?

I didn’t try this but will try within next few hours. I will try it on my local machine and then on new server instance.(Cloud based)

I guess if the free -h dumps are a precise enough measurement you have the answer there! So, buy more RAM :smile: agree?

Possibly you can explore more with e.g. top etc.
(I’m by no means expert on reading output from those tools - but here’s maybe a starting point)

Update: Also if you’re running Java 9 this looks relevant:


Exactly :slight_smile: I got it while executing these commands that I need more RAM to get metabase to work.

Thanks @jornh, You’ve amazing community for Metabase!


1 Like