Minimal working setup for LDAP authentication

I tried setup LDAP authentication from the sample configuration in the doc. But I can't get it work.
Metabase, recognize there is envvar for LDAP, but don't give a way to configure it :

Am I missing something?

Is this cloud or self-hosted? Open source or paid?

LDAP is due to be dropped from open source (not sure of exactly when, lots of people complaining).

I've never seen that message! Perhaps it's been added to the lowest tier of cloud hosting?

Thanks for your answer!

It is self-hosted open source (not paid) version.
With Metabase last version (v0.48.8).
I ran it with docker compose from the example given in the doc:

version: '3.7'
    image: metabase/metabase:latest
    container_name: metabase-ldap
    hostname: metabase-ldap
    - /dev/urandom:/dev/random:ro
      - 3000:3000
      - metanet1
      - "MB_LDAP_BIND_DN=cn=admin,dc=example,dc=org"
      - "MB_LDAP_ENABLED=true"
      - "MB_LDAP_GROUP_BASE=cn=readers"
      - "MB_LDAP_HOST=openldap"
      - "MB_LDAP_PASSWORD=adminpassword"
      - "MB_LDAP_PORT=1389"
      - "MB_LDAP_USER_BASE=ou=users,dc=example,dc=org"
      # We are using the same field for email and first name, just for this example to work without modifications to the LDAP objects
    image: bitnami/openldap:2.4.57
    hostname: openldap
    container_name: openldap
      - 1389:1389
      - LDAP_ADMIN_PASSWORD=adminpassword
      - LDAP_PASSWORDS=password1!,password2!
      - LDAP_PORT_NUMBER=1389
      - LDAP_ROOT=dc=example,dc=org
      - LDAP_USER_DC=users
      - LDAP_GROUP=readers
      - metanet1
    driver: bridge

And the LDAP server is working and reachable from the Metabase container.
But I was wondering if there is any additional step required to get a setup panel for LDAP in the Admin -> Authentication of Metabase?

Also thanks for the information that:

LDAP is due to be dropped from open source

This is something we should consider

Odd. Server I'm working on this afternoon is on a container. LDAP configuration looks normal. I didn't configure it though, so not sure of the difference.
What happens if you go to

Thanks for your answer, it worked with the direct URL:

And from that, I've be able to set it up :smiley:!

I don't know if it's something to do with my config, it seems that from http://"your-server-name"/admin/settings/authentication/… pages environment variables are not well managed.
This is what I get, when I save and enable after adding a mapping between DN and Metabase group:

But it worked anyway, so it's most likely a presentation issue :wink: