MongoDB Connection Problem

I’m trying to connect Metabase to MongoDB 4.0 (running Metabase through docker)

I have not setup username and password on mongo.
The Connection UI requires username and password otherwise one can’t save the connection.

Is there a way around the connection settings?
Where could I set a URI?
Also the SSH connection settings don’t allow for a key file. (yet?)

At the moment the connection wizard seems very limited.

Was there anyone successful with connecting to Mongo?

Related issue (with a workaround):

You are right regarding ssh keys, which has an open enhancement request: