MongoDB Report last 30 days and report by date Various data

We have a problem that we can not solve for several days. We have a MongoDB base and date cells in it are stored in Unixtime by seconds. When changing the data representation from Unixtime to date, the conversion works fine. But when plotting graphs, the sum of the results by day is not considered correct. The time on the server is set to Europe / Moscow, in the docker container and the JVM is similar. Screenshot of the report last 30 days:
And a report for a specific date:

The amounts do not match by day, but the request is the same.
I think the problem is in the time zone when building a request for 30 days, but I have already tried all the methods to fix it. Problem on the Metabase side.
Can you help with this problem?

Hi @kotik2145
Post "Diagnostic Info" from Admin > Troubleshooting.
I don't understand your screenshots. Which one is supposed to be correct?
It sounds like, but it's hard to tell with limited info.

"browser-info": {
"language": "ru-RU",
"platform": "MacIntel",
"userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/97.0.4692.71 Safari/537.36",
"vendor": "Google Inc."
"system-info": {
"file.encoding": "UTF-8",
"": "OpenJDK Runtime Environment",
"java.runtime.version": "11.0.13+8",
"java.vendor": "Eclipse Adoptium",
"java.vendor.url": "",
"java.version": "11.0.13",
"": "OpenJDK 64-Bit Server VM",
"java.vm.version": "11.0.13+8",
"": "Linux",
"os.version": "5.4.0-88-generic",
"user.language": "en",
"user.timezone": "Europe/Moscow"
"metabase-info": {
"databases": [
"hosting-env": "unknown",
"application-database": "h2",
"application-database-details": {
"database": {
"name": "H2",
"version": "1.4.197 (2018-03-18)"
"jdbc-driver": {
"name": "H2 JDBC Driver",
"version": "1.4.197 (2018-03-18)"
"run-mode": "prod",
"version": {
"date": "2022-01-10",
"tag": "v0.41.6",
"branch": "release-x.41.x",
"hash": "296635f"
"settings": {
"report-timezone": "Europe/Moscow"

help please

@kotik2145 Like I already posted, sounds like you are seeing issue 11149. Read through all the comments. Unless you can get the possible workaround to work, then there's no solution unless you change your unix timestamps to a timestamp with timezone via a view.