My cpu usage increases to 249% and the dbug log showing PermGen space exception

metabase stops working due to PermGen space exception and cpu uses increases to very much on my ubuntu server even when we do not use metabase and now it has become quite often.

And i have even tried running metabse by giving it 4gb of space but same problem

this is a debug log

That’s weird. We’re running it on 512MB VMs without too much drama, and 4GB on production workloads at medium sized companies with no hickups.

What’s at the top of the logs? It seems like something’s going very wrong before this point.

Do you have metabot/slack integration enabled?

yes sameer i have a slack integration as pulse and thanks turning the pulse off helped me now every thing seems normal . So is there any bug in pulse or something else

Not sure. In general, we have trouble with the Slack API. I noticed the Metabot timeout in the top of your screenshot, and I’m guessing we’re not cleaning up after ourselves on a websocket drop.

If you’re able, can you turn slack back on and see if any errors hit the logs?

What JVM are you using? If it’s an older Oracle one or an open-source one I don’t think classes are GC’ed, which would explain the PermGen OOM error. Clojure tends to make a lot of little classes.

Try -XX:+CMSClassUnloadingEnabled in conjunction with -XX:+UseConcMarkSweepGC; the former makes classes in PermGen eligible for GC while the second needs to be used for class unloading to be enabled.

@sameer sameer making removing slack integration only reduced the cpu uses problem premgen is still there an metabase not working @camsaul i have tried -XX:+CMSClassUnloadingEnabled in conjunction with -XX:+UseConcMarkSweepGC also but PremGen still there below are the logs

What JVM are you using?

java version “1.7.0_80”
Java™ SE Runtime Environment (build 1.7.0_80-b15)
Java HotSpot™ 64-Bit Server VM (build 24.80-b11, mixed mode)

i updated my java to 1.8 and problem solved i dont know what was the problem with 1.7

metabase version 0.19 jar is working fine. When i have updated to latest version which is 0.20 had high cpu usage issue and bis not even worked. Latest version having some issues though.

@ravi_kishore which OS + JRE are you using?

Ubuntu 14.04.5 LTS
java version “1.8.0_101”
Java™ SE Runtime Environment (build 1.8.0_101-b13)
Java HotSpot™ 64-Bit Server VM (build 25.101-b13, mixed mode)