Mysql connection issue


I'm having trouble connecting to the new database using the ssh tunnel.
The current configuration already has two databases with identical new connection settings, and they work. The new one gives the following error when trying to establish a connection -

Could not connect to address=(host=localhost)(port=46529)(type=master) : RSA public key is not available client side (option serverRsaPublicKeyFile not set)

Metabase installed as a JAR file.

Hi @KreyDan
Post "Diagnostic Info" from Admin > Troubleshooting.
The difference is the MySQL version or authentication type:

Hello @flamber,

  "browser-info": {
    "language": "en-GB”,
    "platform": “MacIntel”,
    "userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/16.0 Safari/605.1.15”,
    "vendor": "Apple Computer, Inc.”
  "system-info": {
    "file.encoding": "UTF-8”,
    "": "OpenJDK Runtime Environment”,
    "java.runtime.version": "11.0.16+8-post-Ubuntu-0ubuntu120.04”,
    "java.vendor": “Ubuntu”,
    "java.vendor.url": "“,
    "java.version": “11.0.16”,
    "": "OpenJDK 64-Bit Server VM”,
    "java.vm.version": "11.0.16+8-post-Ubuntu-0ubuntu120.04”,
    "": “Linux”,
    "os.version": "5.4.0-96-generic”,
    "user.language": “en”,
    "user.timezone": "Etc/UTC”
  "metabase-info": {
    "databases": [
    "hosting-env": “unknown”,
    "application-database": “mysql”,
    "application-database-details": {
      "database": {
        "name": “MariaDB”,
        "version": "10.3.34-MariaDB-0ubuntu0.20.04.1”
      "jdbc-driver": {
        "name": "MariaDB Connector/J”,
        "version": “2.7.6”
    "run-mode": “prod”,
    "version": {
      "date": "2022-09-29”,
      "tag": “v0.44.4”,
      "branch": "release-x.44.x”,
      "hash": “382d728”
    "settings": {
      "report-timezone": null

And the problem is that it is not a database for the metabase application, it is one of the databases on the basis of which we want to generate statistics, ie connection error occurs within the web interface when you try to add it.

@KreyDan Then add allowPublicKeyRetrieval=true to Additional JDBC connection string:

@flamber Oh, thank you so much, it works.

It's a little unclear why the other two started without this option.