Navicat vs Metabase - The Speed of running Mysql

I tried to run the mysql command on Navicat and Metabase which got totally differnt time.

Take example, I run the same command, like "select * from table_name where time>“2020-04-01”, in Navicat, it takes 1 second , and Metabase takes 10 times.

I’m not sure why it happened? And I already tried to cut the elements from “Select”, and keep the select as small as I can, but nothing change.

Hi @ScugZd
Please post “Diagnostic Info” from Admin > Troubleshooting.
And I’m guessing you’re not running Metabase and Navicat on the same machine, so could it be a network issue?

Maybe not the network issues, as I run the navicat and metabase on different machines, navicat is on my desktop and matabase is running in cloud server.

@ScugZd But where’s the MySQL database in context to Navicat and Metabase? Unless it’s on the same machine, then it could very well be a network issue.
Also check the log to see if the query is executed when you expect (click). Admin > Troubleshooting > Logs.

They all use the database in cloud server, I mean the same server

@ScugZd Okay, then it’s very likely a network issue between them. If I access your MySQL, then latency and a lot of other things will be very different than if you access it.
Without more details and you checking the response timings, then it’s impossible to know what’s going on.

Otherwise just try to setup Metabase locally on your computer and connect it to your MySQL, and check if that makes a difference