No horizontal scroll on overflowing pivot table on dashboard

Recently discovered this issue when creating a new pivot table and adding it to a dashboard. The pivot table overflows both vertically and horizontally. Vertically you can scroll down but there is no way to scroll horizontally. Also should note there is no scroll bar shown for the vertical scroll as there has been in the past.
Reproduced with sample DB:

Diagnostic info:
{
"browser-info": {
"language": "en-US",
"platform": "Win32",
"userAgent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/116.0.0.0 Safari/537.36 Edg/116.0.1938.62",
"vendor": "Google Inc."
},
"system-info": {
"file.encoding": "ANSI_X3.4-1968",
"java.runtime.name": "OpenJDK Runtime Environment",
"java.runtime.version": "17.0.2+8-LTS",
"java.vendor": "Red Hat, Inc.",
"java.vendor.url": "https://www.redhat.com/",
"java.version": "17.0.2",
"java.vm.name": "OpenJDK 64-Bit Server VM",
"java.vm.version": "17.0.2+8-LTS",
"os.name": "Linux",
"os.version": "4.18.0-305.45.1.el8_4.x86_64",
"user.language": "en",
"user.timezone": "UTC"
},
"metabase-info": {
"databases": [
"sqlserver",
"postgres",
"h2"
],
"hosting-env": "unknown",
"application-database": "postgres",
"application-database-details": {
"database": {
"name": "PostgreSQL",
"version": "15.3"
},
"jdbc-driver": {
"name": "PostgreSQL JDBC Driver",
"version": "42.5.4"
}
},
"run-mode": "prod",
"version": {
"date": "2023-10-26",
"tag": "v0.47.6",
"branch": "?",
"hash": "3a7ed7a"
},
"settings": {
"report-timezone": null
}
}
}

1 Like

Hi there,

I see you're having trouble with a pivot table in your dashboard. It's acting up by overflowing both up and down and left to right. While you can scroll down, scrolling horizontally isn't working, and there's no vertical scroll bar showing up like it used to.

To help you out better, could you provide some additional info?

  1. Browser Info:
  • Language: English (United States)
  • Platform: Win32
  • Browser: Google Chrome (Version 116.0.0.0)
  1. System Info:
  • OS: Linux (Version 4.18.0-305.45.1.el8_4.x86_64)
  • Java Version: 17.0.2
  • Timezone: UTC
  1. Metabase Info:
  • Databases: SQL Server, PostgreSQL, H2
  • Hosting: Unknown
  • Metabase Version: v0.47.6 (released on 2023-10-26)

I check your URL: https://www.redhat.com/msbi
Best,

Language: English
Platform: Windows
Browser: Microsoft Edge Version 116.0.1938.62 (Official build) (64-bit)

OS: Windows 10 Enterprise
Java Version: 17
Timezone: UTC

Metabase Info: : v0.47.8 (just updated, also did not work on 0.47.6)
Databases: PostgreSQL

Please post a picture of the question definition

So, are you saying this hasn't been solved? Will it be solved? Should I make a github issue?