No matching clause: 535 5.7.8

I’m setting up email but I keep getting the error “No matching clause: 535 5.7.8”

I know that the Host, Port, Security, Username, Password are correct. I’m using Sparkpost.

Host is smtp.sparkpostmail.com
Port is 587
Security is STARTTLS
Username is SMTP_Injection
Password is the API key

Hi @tanner
Which version of Metabase?
Shouldn’t you use TLS as Security instead of STARTTLS?
You should see a bit more details if you look in the Metabase log.

EDIT: A quick search on the error code, seems to suggest that it’s just bad credentials:
https://stackoverflow.com/questions/16784368/smtp-error-535-5-7-8-authentication-credentials-invalid

I made sure the API key was correct… I’ll generate another one just to see

Screenshot_080519_073657_PM

Metabase Version

@tanner
Did it used to work with 0.32.x?
Have you tried using the credentials with another program/code on the same machine running Metabase, just to see if all the info works?

I just installed it on heroku. Not sure if it works on the same server, but I have used Sparkpost on other servers and it worked? I’m not sure what I should do to test it further

@tanner
Okay, so you’ve never used Sparkpost with Metabase before?
And you only have Metabase 0.33.0-RC1?
Do you see any further error details in the Metabase log?