No suitable driver found for JDBC

Hello

I set up Metabase with AWS EB, once I try to connect to my snowflake DWH, I get the following error.

I found no help online, can someone please help?

Hi @gmwill934
Which version of Metabase?
Can you check the log for any errors earlier, like unpacking the drivers? Admin > Troubleshooting > Logs

Lastest version, 0.33.2.

Blockquote 09-20 19:15:57 e[1mERROR driver.utile[0m :: Database connection error
java.sql.SQLException: No suitable driver found for jdbc:snowflake://wm@francismorgan.mx.snowflakecomputing.com/
at java.sql/java.sql.DriverManager.getConnection(Unknown Source)
at java.sql/java.sql.DriverManager.getConnection(Unknown Source)
at clojure.java.jdbc$get_driver_connection.invokeStatic(jdbc.clj:271)
at clojure.java.jdbc$get_driver_connection.invoke(jdbc.clj:250)
at clojure.java.jdbc$get_connection.invokeStatic(jdbc.clj:411)
at clojure.java.jdbc$get_connection.invoke(jdbc.clj:274)
at clojure.java.jdbc$db_query_with_resultset_STAR_.invokeStatic(jdbc.clj:1093)
at clojure.java.jdbc$db_query_with_resultset_STAR_.invoke(jdbc.clj:1075)
at clojure.java.jdbc$query.invokeStatic(jdbc.clj:1164)
at clojure.java.jdbc$query.invoke(jdbc.clj:1126)
at clojure.java.jdbc$query.invokeStatic(jdbc.clj:1142)
at clojure.java.jdbc$query.invoke(jdbc.clj:1126)
at metabase.driver.sql_jdbc.connection$can_connect_QMARK_.invokeStatic(connection.clj:123)
at metabase.driver.sql_jdbc.connection$can_connect_QMARK_.invoke(connection.clj:118)
at metabase.driver.sql_jdbc$fn__66954.invokeStatic(sql_jdbc.clj:35)
at metabase.driver.sql_jdbc$fn__66954.invoke(sql_jdbc.clj:34)
at metabase.driver.snowflake$eval546$fn__548.invoke(snowflake.clj:238)
at clojure.lang.MultiFn.invoke(MultiFn.java:234)
at metabase.driver.util$can_connect_with_details_QMARK_$fn__19324.invoke(util.clj:30)
at metabase.util$do_with_timeout$fn__6283.invoke(util.clj:334)
at clojure.core$binding_conveyor_fn$fn__5754.invoke(core.clj:2030)
at clojure.lang.AFn.call(AFn.java:18)
at java.base/java.util.concurrent.FutureTask.run(Unknown Source)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.base/java.lang.Thread.run(Unknown Source)
09-20 19:15:57 e[1mDEBUG middleware.loge[0m :: e[31mPOST /api/setup/validate 400 494.7 ms (0 DB calls)
{:errors {:dbname “No suitable driver found for jdbc:snowflake://wm@francismorgan.mx.snowflakecomputing.com/”}}

@gmwill934
So there are no errors earlier, when Metabase is starting up and loading drivers?
Does it even load the driver part of lazy-load?
INFO metabase.driver :: Registered driver :snowflake (parents: [:sql-jdbc])

No errors really, just this when getting data.

@gmwill934
But does it even load the Snowflake driver?

Hmmm no, I see no other than the image that I uploaded.

@gmwill934
Please post the entire log from when Metabase was starting until you try to setup the Snowflake database, which fails with an error.

Got it working, now I get the following, i’m pretty sure i’m using my correct username and password.

@gmwill934
How did you make it work?
I’m guessing you might be seeing this issue, which needs the account name and region id to be entered in the deprecated way:
https://github.com/metabase/metabase/issues/10142

I’m including the region. Please take a look.

image

Solved it by adding the account and region name separately.

Thank you so much for your help.

1 Like

@gmwill934
Can you please explain how you solved your initial problem with “No suitable driver found for JDBC” ?
Just in case someone from the future has the same problem :+1:

Yes, so I was trying to connect to my snowflake data warehouse using Metabase version 0.33.2.

I solved the error by putting my account name and region name separately.

(labels where typed with my mouse, i apologize)

1 Like

Not able to connect, below is the error message

03-21 12:53:06 e[1mDEBUG middleware.loge[0m :: POST /api/database 400 5.0 s (0 DB calls)
{:valid false, :dbname “Timed out after 5.0 s”, :message “Timed out after 5.0 s”}

03-21 12:53:07 e[1mDEBUG middleware.loge[0m :: GET /api/database 200 2.6 ms (3 DB calls) Jetty threads: 5/50 (3 idle, 0 queued) (47 total active threads) Queries in flight: 0
Mar 21, 2020 12:54:10 PM net.snowflake.client.jdbc.RestRequest execute
SEVERE: Stop retrying since elapsed time due to network issues has reached timeout. Elapsed: 67,506(ms), timeout: 60,000(ms)