Non-Admin, Non-Test users unable to see some saved questions

Recently we have added a new collection of questions. When sending the links to some of these questions to members of the team that are not Metabase admins (and also not test users), they have been told that they don’t have permission to view the question. The problem goes away when they are made an admin, but we don’t want to make everyone an admin.

I looked at the Permissions tab and saw a row for each of our data sources, and then another row called “Saved Questions.” It said data access and SQL queries were both denied for all users. I tried to change this, but it would not save with the new settings. When I refreshed, the row for “Saved Questions” disappeared entirely.

How can I ensure that all my team members have access to the saved questions? This seems like a bug.

Hi Maryrose, have you checked that the permissions on your new collection are correctly set? Whenever I create a new collection the default permission is set to “No Access” for normal users.
So to be clear I don´t mean the permissions on group level but on collection level:

Maybe that helps?
Cheers, Eva

That was it! Thank you! Interesting that I’ve never had to do that for a collection before.

1 Like